Compatibility

Our agent is designed to work with most use-cases. Below you will find details on versioning, application stacks, and known incompatibility issues.

Version Support

The Bearer Agent supports Go v1.13 or higher and requires that Go modules are enabled.

Application Stacks

The agent supports Go environments that rely on the standard library's HTTP package. Support for additional transports can be added by creating a custom transport.

Known limitations

Features not supported

The Go agent currently supports a subset of Bearer's features, including the primary monitoring experience. The following are coming soon, but not currently supported:

  • Remediations: Currently, the Go Agent does not support active remediations.

Serverless functions-as-a-service

While the agent will work in many function-as-a-service scenarios, such as in AWS lambda functions or Google Cloud functions, some remediations types (like retrying failed requests) may not work as expected if the lifespan of the function is too short.

Receiving Support

If you experience an issue installing or using the agent, let us know! You can contact us directly, chat with a member of the team using the Intercom icon in the lower right corner of this page, or check out our Help Center.

‚Äč